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Introduction
This Boardmaker Software Family Handbook was written to support version 6 of the complete
Boardmaker® software family of products: Boardmaker (BM), Boardmaker Plus! (BM+), and Boardmaker
with Speaking Dynamically Pro (BM with SDP).
Boardmaker is a graphics database containing over 35,000 Picture Communication
Symbols (PCS) that can be used to create a variety of printed communication and
educational materials. The symbols can be used in any size, in color or black and
white, and displayed with text in a variety of languages.
Boardmaker Plus! allows you to bring static Boardmaker activities to life and make
your computer an interactive student learning and speaking tool. It features the ability
to talk, play recordings, move between boards, and interact with buttons on the screen.
Boardmaker Plus! allows you to create interactive books, worksheets, schedules,
basic communication, learning games, and more.
Boardmaker with Speaking Dynamically Pro includes all of the interactive features of
Boardmaker Plus! with the addition of word prediction, abbreviation expansion, and
high-quality RealSpeak® voices.
To help identify the topics that apply to the Boardmaker software family product you purchased, product
icons (as shown above) will appear next to the title of each topic in this handbook.
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Getting Started

In-Program Help
This Boardmaker Software Family Handbook is an
introduction to the basic skills you will need to start
creating fantastic printed materials and/or interactive
activities with the program. This handbook is intended to
immediately get you “up and running” by focusing on a
brief overview of key, frequently used features of the
program.
All of the topics included here are covered in greater detail
in the in-program help. Many other features of the
program, including advanced features, are not covered
here at all, but are instead included in the in-program help.
Refer to the in-program help for information not included in
this handbook. Select Help Topics from the Help menu to
access the browser-based in-program help, which
includes step-by-step procedures for all of the many
features available in the Boardmaker Software Family of
products.
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Getting Started

Getting Started
1.
2.

3.

Insert the product CD into your computer’s CD
drive.
Double-click on the BSF product icon on your
desktop.

Click on one of the three buttons to start working
on a new board, work with a saved board, or
open one of the many template or sample
boards.

System Requirements:

•
•

Windows 2000, XP, or Vista
400 MB available hard drive space

Note: If you have Boardmaker Plus! or Boardmaker with Speaking Dynamically Pro, you
can also click on the Interactive Sample Boards icon on your desktop to open the
program and view the sample boards.
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Templates and Sample Boards
Templates for Printing
All of the BSF products come with hundreds of print
templates. These include templates for printing
calendars and schedules as well as templates for
most communication devices.

Click here to
access all
template boards.

To access these templates, click the Open a
Template button on the Open Options screen that
appears when you first open the program (or select
Open from the File menu).
Note: The templates are “read only” files and the
selected template will open as an “untitled board”
so you cannot accidently write over it.
Navigate to
the desired
template.
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Interactive Sample Boards
Boardmaker Plus! and Boardmaker Speaking Dynamically
Pro come with over 600 sample boards and templates that
include the on-screen interactivity of voice and animation.
Select the Open a Template button on the Open Options
screen. Double-click on the Interactive Sample Boards
folder and choose +Main board to open it. Click on the
buttons on the +Main board to explore the sample boards.
Boardmaker Plus! and Boardmaker Speaking Dynamically
Pro both have a Use mode that allows you to interact with
your boards. The program can be put in the Use mode by
pressing Ctrl + U. Return to the Design mode (the Editor
window) by pressing Esc or Ctrl + D.
Notes: You can also launch the program, open the + Main
board, and place the program in the Use mode by
double-clicking the Interactive Sample Boards icon
on your desktop.
When you have explored the sample boards, you can
explore the contents of the Interactive Templates
folder.
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Toolbar at a Glance

1

2

3

4
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1 Symbol Finder Tool

8 Symbolate Button Tool

2 Pointer Tool

9 Color Tool

3 Button Tool

10 Thickness Tool

4 Freeform Button Tool

11 Corner Tool

5 Button Sprayer Tool

12 Shadow Tool

6 Line Tool

13 Zoom In / Zoom Out Tools

7 Text Tool
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Draw Window at a Glance
2

1
3

4
1 Board
2 Toolbar
3 Board Workspace
4 Symbol Finder Window
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Symbol Finder at a Glance
3
4
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1
2

Current Symbol

8

Current Symbol Number

Use to select a symbol category to search

Reflects the number of search matches

3

9

Match anywhere in name

10 Alternate Symbol Name Field
Type in this field to replace the current symbol’s
name with a new name. This is a one-time name
change.

Match to whole word in name

4

Minimize, Restore, Close Buttons

5

Search Text Field
Type the name (or part of the name) of the
symbol you wish to find.

6

11 Alternate Symbol Names List
Displays a list of alternate names for the current
symbol. You may select any name from the list.

12 Settings Button
Use to change various Symbol Finder settings,
such as display languages, font sizes, libraries, etc.

Thumbnails View Button
Displays thumbnails that match your current search

Symbol Names Button
Use to add an alternate name or category to the
current symbol

Symbol Name Search Options
Match to beginning of word in name

Categories Button

13

7 Previous/Next Arrows

Selection Marquee/Lasso
Toggles between the marquee and lasso tools

Step through symbol or thumbnail screens
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Creating a Button
Use the Button Tool to draw buttons wherever you want
them. The buttons you create with the Button Tool can
be of different sizes and can be square or rectangular.
1.
2.
3.

4.

Select the Button Tool on the Toolbar.
Move the cursor into the board workspace.
Click, hold, and drag diagonally to draw a button.
Release the mouse when the button is the size you
want.
Select the Button Tool again to draw your next button.

Notes: Buttons must be a minimum of 1/4” by 1/4”.
To make a square button, hold down the Shift key
while dragging out the button.
Use the Pointer Tool to resize a button. First, select
the button with the Pointer Tool. Move the cursor
over any corner until a double arrow appears. Click,
hold, and drag to change the button’s size.
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Creating a Grid of Buttons
You can create a grid of identical buttons using the
Button Sprayer Tool.
1.

2.
3.

Using the Button Tool, move the cursor into the board
workspace. Click and drag diagonally to create the
initial button for your grid.
Select the Button Sprayer Tool.
Move the Button Sprayer Tool on top of the button
you just created. Click, hold, and drag diagonally to
spray out a grid of buttons.

Note: You can reposition the buttons while they are still
selected (they will have dotted green outlines). Click
and drag any button to reposition the entire grid.

11

Initial
Button
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Finding a Symbol
The Symbol Finder lets you quickly search for a
specific symbol.
1.
2.

3.
4.

Select the Symbol Finder Tool to open the Symbol
Finder.
Type the name of the symbol that you want to find
in the Search Text field of the Symbol Finder.
(Refer to Symbol Finder at a Glance on page 8.)
Use the Previous/Next Arrows to step thru all the
matching symbols one at a time.
Alternately, you can click on the Thumbnails
button to view thumbnails of all the symbols that
match your search.

Note: If there are numerous symbols that match your
search, you can use the Previous/Next Arrows
to step through all the pages of thumbnails.
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Copying a Symbol to a Button
When you have found the symbol you want to use,
you can place it in the highlighted button (the first
available empty button), in any specific button, or on
the background.
Press the Enter key to place the symbol in the
highlighted button.
Click on a specific button or on the background with
the Placement Cursor to place the symbol in that
location. (When the Symbol Finder is open, the cursor
automatically changes to the Placement Cursor.)
Note: You can position and size the symbol within a
button or on the background by clicking and
dragging with the Placement Cursor as you
place the symbol.

Press Enter to
place symbol in
highlighted
button.
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Click with
Placement
Cursor to place
symbol on any
button.
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Assigning Button Actions
You can make your boards interactive by assigning
actions to your buttons. When you double-click on a
button, the Button Actions dialog (shown to the
right) will appear. There are over 135 button actions
from which to choose. You can assign multiple
actions to each button.

2

1

3

Actions are organized into tabbed categories. Click a
tab to access related button actions. There are nine
action categories:
• Basics

• Text & Cursor

5

• Variables

• Messages

• Message Files

• Quick Actions

• Board Change

• Settings

• Cool Stuff

The most commonly used actions are in the Basics
tab.
Note: Only an overview of button actions is included
here. Refer to Boardmaker (in program) Help
topics for detailed information on button actions.

6

4

1

Action Menu

2 Action Categories

4 Play/Delete Buttons
5 Assigned Actions List

3 Dynamic Help Window 6 Action Details List
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Making a Button Speak
You can specify the text you want a button to speak, or
you can make a button automatically speak the text on
its face.
1.
2.
3.

Double-click the button you want to speak. The Button
Actions dialog will appear.
Select Speak Message in the Action menu
(Basics tab).
Enter the message you want the button to speak.

Double-click on button
you want to speak.

Select Speak
Message in
the Action
menu.

Or, if you want the button to automatically speak the
text on the button face, click the Use Button Text
button.
Note: You can preview your message by clicking on the
Speak button.

4.

Click the OK button when you’re finished.
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Enter text
you want
button to
speak.
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Making a Button Play a Recording or Sound
You can embellish your activities by making a button play
a saved sound. You can record a new sound, use a sound
file you have saved with another board or on your
computer, or you can use one of the 157 prerecorded
sounds provided in the MJ Sound Library.
1.
2.

3.

4.

Double-click the button you want to play a sound. The
Button Actions dialog will appear.
In the Action menu, select Play Recorded Message
(the sound will play when you click on the button) or
Recorded Preview (the sound will play when you
glide over the button). The Record Sound dialog will
appear.
Select Record a New Sound to use the built-in
microphone on your computer to record a new sound,
or click the appropriate button to select a sound
saved on another board, on your computer, or to
choose a sound from the MJ Sound Library.
Enter a name for your recording or sound when
prompted, and click OK when you are done.
16

Double-click on button you
want to play a sound.

Select Play Recorded
Message (or Recorded
Preview) in the Action
menu.

Click the
appropriate
button to select a
sound source.
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Trying Out Button Actions in the Use Mode
As you discovered when you were exploring the sample
boards, Boardmaker Plus! and Boardmaker Speaking
Dynamically Pro have a Use mode that allows you to
interact with your boards. While you are assigning button
actions, you will want to try them out in the Use mode.

In Design mode
you can see the
toolbars. This is
where you design
the activity.

Put the program in the Use mode by selecting Use in the
Dynamic Boards menu (or by pressing Ctrl + U.)
Try out the button actions by clicking on the buttons to
which you have assigned actions.
Return to the Design mode by selecting Design in the
Dynamic Boards menu (or by pressing Esc or Ctrl + D.)
Continue assigning button actions, or you can edit the
actions you have already assigned. (See Editing a Button’s
Assigned Actions on page 18.)
As you continue exploring this handbook and learning to
use some of the interactive features of Boardmaker Plus!
and Boardmaker Speaking Dynamically Pro, remember to
frequently switch to the Use mode to try out all the
interactive features of the boards you are creating.
17

In Use mode the
activity takes up
the entire screen.
This is where you
test the activity and
where the user will
access the activity.
This button has
been assigned
the Speak Text
(use Button
Text) action.

“DOG”

Getting Started

Editing a Button’s Assigned Actions
The actions you have assigned to a button can easily be
edited, added to, deleted, or rearranged. Double-click on the
button you wish to edit. The Assigned Actions list for that
button will appear.

Click and drag to
change the order of
assigned actions.

Editing an assigned action:
Double-click the action in the Assigned Actions list you
want to edit. Make your changes in the dialog that appears.
Adding an action to the list:
Select the action in the Assigned Actions list you want to
precede the new action. Assign the new action to the
button.
Rearranging assigned actions:
Click and drag any action to a different location in the
Assigned Actions list.

Any action added
to a button will
appear after the
highlighted action.

To delete an action,
select it, and then
click the Delete
button.

To edit an action,
double-click it, and
make your changes in
the dialog box.

Deleting an assigned action:
Select the action in the Assigned Actions list, and click the
Delete button.
18
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Saving a Board
Be sure to save your boards as you create them. The
default location for saving boards is the My Boards
folder within the My Documents folder on your
desktop. If you are creating boards for different users
or different activities, you might want to create
separate folders within the My Boards folder to keep
your boards organized. (This is especially important if
you are planning on linking boards together, because
all boards that you plan to link together must be saved
in the same folder.)
1.

2.
3.

Select File > Save As. (If you want to create a new
folder within the My Boards folder, click the New
Folder icon in the Save As dialog. The system
will create an untitled “New Folder.” Type in a
name for the new folder.)
Type a name for the new board in the File Name
text box.
Click the Save button.
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Selecting the Board Orientation
You can lay out your boards in either landscape or
portrait orientation (the default is landscape). You
can change the orientation setting for a specific
board if necessary, or you can change the default
setting for all new boards.
1.
2.

3.
4.

Select File > Print Setup.
Click the Use Printer Page button. (This
matches the board size to the maximum print
area allowed by your printer for a single sheet
of paper.)
Select Portrait or Landscape from the Print
Setup menu.
Click the OK button.

Note: To preserve your settings for new boards,
click on either the Remember Board
Settings for New Boards or Remember
Printer Orientation for New Boards button.

1

2

3
4

1 Use Printer Page Button
2 Print Setup Button
3 Remember Board Settings Button
4 Remember Printer Orientation Button
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Using Drag and Drop

Dragging & Dropping an Image to a Button
You can personalize your activities by adding
graphics or photos that you have saved on your
computer or that you find on the Internet.
1.
2.
3.

Locate an image you want to add to a button.
Click, hold, and drag the image onto a button.
Release the mouse button.

Note: The image will be labeled with its file name. To
prevent the file name from displaying, hold down
the Alt key when you drop the image onto the
button.
Tip:

If Boardmaker is not visible, drag the image to the
Boardmaker icon in the Windows task bar. Wait
until Boardmaker becomes the active program,
and drop the image.
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Dragging & Dropping an Image to the Board Background
You can drag and drop graphics and photos to the board
background the same way you dragged and dropped
them to a button.
1.
2.

Locate an image you want to add to the board
background.
Drag the image to the board background, and
release the mouse button. The image will be scaled
to fit the entire board.

Tips:

Hold down the Ctrl key while dragging the image to
scale the image to fit a 2-inch by 2-inch square and
include the file name as the label.
Hold down the Alt key to omit the label.
Hold down the Shift key to preserve the image’s
proportions.
If Boardmaker is not visible, drag the image to the
Boardmaker icon in the Windows task bar. Wait until
Boardmaker becomes the active program, and drop
the image.
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Dragging & Dropping Images into the Symbol Finder
Drag and drop can also be used to add new symbols
to your personal symbol library.
1.
2.
3.

4.
5.

Click and drag the
image into the
Symbol Finder.

Open the Symbol Finder.
Locate an image you want to add to the symbol
library.
Using the Pointer Tool, click and drag the image
into the symbol view area of the Symbol Finder
and release the image.
The My Symbols dialog will open. Give the new
symbol a name and assign it a category.
Click the OK button when finished.

Note: Multiple images can be added to the Symbol
Finder at the same time. Select the images you
want to add (hold down the Shift key while
clicking to select multiple images). Drag the
images into the symbol view area of the Symbol
Finder and release the images. The Import
Symbols dialog will open. Choose the proper
naming and category options for the imported
images. Click on the OK button when finished.

Give the image a
name and assign
it a category.
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Dragging & Dropping Sound and Video Files
If you are using Boardmaker Plus! or Boardmaker
Speaking Dynamically Pro, you are not limited to
dragging and dropping graphics or photos. You can
also drop sound files (files with a “.wav” suffix) and
video files (files with “.avi,” “.mpeg,” “.mpg,” or
“.wmv” suffixes) onto your buttons.
1.
2.

Find the sound or video file you want to add to
the button.
Using the Pointer Tool, click and drag the
sound or video file onto the button.
When you drag a sound file onto a button, a
Play Recorded Message action will be added
to the button. When you drag a video file onto
a button, a Play Movie action will be added to
the button.

3.

Click and drag a
sound or video file
onto a button.

Put the program into Use mode to try it out!
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Creating a Symbolate Button
As you type into a Symbolate button, the symbol for
the word you are typing automatically appears.
Symbolate buttons provide a quick and easy way to
create symbol-adapted text.
1.
2.
3.

Select the Symbolate Button Tool.
Click on the background where you want the
Symbolate button to appear.
Begin typing in the new Symbolate button. As
you type, a symbol will appear for each word for
which there is a valid word-symbol match.

Notes: For a symbol whose name contains multiple
words, type an underscore (“_”) between words
rather than a space.
The more symbols to which you have access,
the better the symbolate function will work. The
PCS addendum libraries contain over 9,000
symbols!

25

Working with Symbolate Buttons

Changing Symbolate Symbols
Many words have multiple symbol matches.
Sometimes the first symbol that appears will not be
appropriate for the context in which the symbol is being
used. You can quickly change the symbol to match the
context.
1.
2.

Using the Symbolate Button Tool, click on the word
whose symbol you want to change.
Press the F1 key to step forward through all the
available symbols for the word or the F2 key to
step backward.

When you change a symbol, the change only affects
the symbol in the current Symbolate button. If you like,
you can change the default symbol for the word:
1.

2.
3.

Using the Symbolate Button Tool, double-click on
the symbol you want to change. The Symbolate
Candidates dialog will appear.
Select the symbol you want to use as a default.
Click the Make Default button.
26

Press F1 or
F2 to switch
the symbol.
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Editing Symbolate Text
You can edit and format the text and symbols in a
Symbolate button as needed.
Editing Text:
1.
2.

Select the Symbolate Button Tool.
Click on any word, or between two words, and
begin typing your new text. (You can select only
one word at a time. Backspace to remove multiple
words.) The text will automatically be resymbolated
as it is changed.

Formatting Text or Changing Size of Symbol:
1.
2.

Right-click on the Symbolate button using either the
Pointer Tool or the Symbolate Button Tool.
A contextual menu will appear with options to
format button text, increase or decrease symbol
size, and change the text position.
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Read with Highlighting Action
In Boardmaker Plus! and Boardmaker Speaking
Dynamically Pro, Symbolate buttons can be set to
read each word aloud and highlight each wordsymbol pair as it is spoken.
1.

2.

Using the Pointer Tool, double-click the
Symbolate button you want to read with
highlighting. The Button Actions dialog will
appear.
Select Read with Highlighting in the Action
menu (Basics tab).

Note: If you want just the text (rather than the entire
word-symbol pair) highlighted, select the
Highlight Text Only checkbox.

3.

Click the OK button when you’re finished.

Note: The Read with Highlighting action can only
be assigned to Symbolate buttons.
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Creating a Freeform Button
The Freeform Button Tool lets you draw buttons of any
shape. You can create “hotspots” around parts of a
background picture, give certain buttons a unique look,
or simply create fun new button shapes.
1.
2.
3.

4.

Select the Freeform Button Tool.
Move the cursor into the board workspace.
Click and drag out the shape of the Freeform button.
As you drag the mouse, you will see the button
border appear.
Release the mouse button to automatically close the
button border.

Note: If you draw a Freeform button around a symbol on
the background, the symbol will move to the face of
the button.
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Creating a Polygonal Freeform Button
The Freeform Button Tool can also be used to create
polygonal buttons.
1.
2.

3.

Select the Freeform Button Tool, and press and hold
down the Ctrl key on your keyboard.
While continuing to hold down the Ctrl key, click the
mouse at each point where you want a corner of the
polygon.
To finish your polygonal Freeform button, doubleclick to specify the position of the final corner of the
button (or release the Ctrl key).
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Appearance Options

Adding Color
You can change the color of a button background, of
button text, of the button border, and of the board
background.
1.
2.

3.
Tip:

Using the Pointer Tool, click on the item whose color
you want to change.
Select the Color Tool. The Color Palette will open.
(If you have selected a button, click on either the
Button or Border tab at the top of the Color Palette
before selecting a color.)
Click on the color you want to use.

Select the
Color Tool

Click on the eyedropper to select and use a color that
is not in the Color Palette but appears elsewhere on
the board.

Click on the desired color
in the Color Palette.
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Changing the Button Shape
Use the Corner Tool to change the shape of buttons
you have drawn.
1.
2.
3.
Tip:

Using the Pointer Tool, click on the button(s) whose
shape you want to change.
Select the Corner Tool.
Select the desired corner shape in the Corner
Shape drop-down menu.
If you select a Freeform button, the Corner
Shape drop-down menu will display polygons.
This is an easy way to convert a Freeform button
to a regular polygon. (Hold down the Shift key
while selecting a shape to create a regular
polygon with all sides the same length.)
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Changing the Button Border Thickness
The Thickness Tool allows you to change the thickness
of a button border or of a line you have drawn. (See
Adding a Line on page 35.)
1.

2.
3.

Using the Pointer Tool, click on the button whose
border you want to change (or on a freehand line you
have drawn using the Line Tool).
Select the Thickness Tool.
Select the desired thickness in the Thickness dropdown menu.

Note: The dashed line in the drop-down menu indicates
“hidden” borders. When the button is selected, it will
appear onscreen with a light gray dot-dash border,
but this border will not print out.
Tip:

To apply a dashed border that will print out, rightclick a button and select Properties > Dashed
Border.
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Applying 3-D Button Shadows
Using the Shadow Tool, you can apply a shadowbox
effect to a button border.
1.
2.
3.

Using the Pointer Tool, click on the button(s) whose
border you want to shadow.
Select the Shadow Tool.
Click on the left-hand button in the Shadow Tool
drop-down menu to turn button shadowing on. Click
on the right-hand button in the Shadow Tool dropdown menu to turn button shadowing off.

Note: You cannot apply 3-D button shadows to Freeform
buttons.
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Adding a Line
The Line Tool lets you draw freehand lines on the board
workspace, as well as on top of (or behind) any button.
1.
2.

Select the Line Tool.
Click, hold, and drag to draw a line.

Note: A line drawn on a button will cut off at the button
border. A line started on the board background that
crosses a button will move behind the button.
Tip:

Use the Thickness Tool to change the line
thickness. (See Changing the Button Border
Thickness on page 33).

Line drawn
on button

Line drawn
behind
button
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Symbol Finder Settings
Boardmaker gives you the options of selecting the
desired language(s) to display with each symbol, the
font size of the text label to display with each symbol,
and the location of the text label relative to the symbol.
1.

2.

3.
4.
5.
6.

Select the Symbol Finder Tool to open the Symbol
Finder. Click on the Symbol Finder Settings button to
open the Symbol Finder Settings dialog.
Use the drop-down menus to select the desired
language(s) for Line 1 Language and/or Line 2
Language.
Select your preferred text size(s) in the Line 1 Size
and/or Line 2 Size drop-down menus.
Choose Use Black & White or Use Color
Symbols.
Set the location of the text label relative to the
symbol.
Click the OK button when you have finished making
your selections.
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Replacing a Symbol on a Button
If you want to replace the symbol on a button, you do
not have to redraw, cut, or clear the button. You can
easily replace the symbol on any button using the
Placement Cursor.
1.
2.
3.

4.

Select the Symbol Finder Tool to open the Symbol
Finder.
Type the name of the replacement symbol in the
Search Text field of the Symbol Finder.
Click on the button whose symbol you want to
replace. (When the Symbol Finder is open, the
cursor automatically changes to the Placement
Cursor.)
A dialog will open. Click the Replace button. The
symbol and text on the button you have
highlighted will be replaced with the new symbol
and text.
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Adding an Additional Symbol to a Button
You can create new symbols by combining two or
more existing symbols from the PCS libraries.
1.
2.

3.

4.
5.

6.

Select the Symbol Finder Tool to open the Symbol
Finder.
Type the name of the symbol you want to add to
your button into the Search Text field of the
Symbol Finder.
Press the Tab key to move to the Alternate
Symbol Name field, and then press the
Backspace or Delete key to remove the symbol
text.
Click on the button that will receive the additional
symbol.
In the dialog that opens, click on the Add To
button. The new symbol will appear on top of the
existing symbol.
Use the Pointer Tool to resize and position the
symbols to fit on the button. (See page 41.)
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Clearing and Deleting Buttons
If you want to change the symbol on a button, you can
clear the symbol and text from the face of the button.
1.
2.

Using the Pointer Tool, select the button(s) you want to
clear.
Select Edit > Clear. (You can also right-click on a
button or group of buttons and select Clear Button >
Face from the contextual menu that appears.)

Right-click
on button

You can also completely delete a button from the board
workspace.
1.
2.

Using the Pointer Tool, select the button you want to
delete.
Press the Delete or Backspace key on your keyboard.

Note: You can quickly delete all buttons or all background
items. Right-click on the background and select
Select All Buttons or Select Background Items
from the contextual menu, then press the Delete key.
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Right-click
on
background

Useful Features

Adding and Resizing Text
Use the Text Tool to add text to a button or to type text
on the board background.
1.
2.

3.
4.
Tip:

Select the Text Tool.
Click the I-beam cursor in the spot where you want
to type the text. The blinking I-beam cursor marks
your position in the text field.
Type in the text.
Use the options in the Text menu to change the font,
style, and size of the text.
The font, style, justification, color, and size of the text
can quickly be changed by right-clicking the text with
the Pointer Tool and selecting options from the
contextual menu.
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Resizing a Button or Graphic
You can easily resize a button or resize the graphic on a
button.
1.
2.

3.
Tip:

Using the Pointer Tool, click on the button or the
graphic that you want to resize.
Move the pointer over any portion of the dashed
selection box until the pointer becomes a double
arrow.
Click, hold, and drag to resize the button or graphic
inside the selection box.
To maintain the proportions of the button or graphic,
hold down the Shift key while resizing the button or
graphic.
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Resizing Buttons and their Contents
You can resize a button and all of its contents (symbol
and text) at the same time. You can also resize only the
button and its symbol and leave the text the same size.
1.
2.
3.
4.
5.

Tip:

Select the Pointer Tool.
Select the button or buttons you want to resize.
Hold down the Ctrl key while you are dragging, and
the button and all of its contents will resize.
To keep the text from resizing, hold down both the
Ctrl and Alt keys while you are dragging.
To keep the proportions of the button and all of its
contents the same, hold down the Ctrl and Shift
keys while you are dragging.
To resize multiple buttons, first select them, then hold
down the Ctrl key and click, hold, and drag on the
dashed selection box surrounding the buttons.
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I want

Hold Ctrl key
while dragging.

Hold Ctrl and
Alt keys
while dragging.

Button and
contents resize.

Text does not
resize.

Useful Features

Alignment and Centering
Using options from the Alignment contextual menu,
you can quickly align buttons, align items within
buttons, or align items on the background. You can
also quickly center content (symbols or text) within a
button.
1.
2.

Right-click on
selected items.

Select the Pointer Tool.
Select the items you want to align or select the
button(s) with the content you want to center.
Right-click on the selected items, and choose an
option from the contextual menu that appears.
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Swapping Buttons
You can easily exchange the positions of two buttons on
your board. The contents of both buttons (symbols, text,
and assigned actions) will be swapped.
1.
2.
3.

4.

Press and hold down the Alt key on your keyboard.
While holding down the Alt key, click on the button
you want to move.
Continue holding the Alt key, and drag the button
over the top of the button to be swapped. (As you
move the button, its original position will be
highlighted.)
When the button to be swapped is highlighted,
release the mouse button.

Notes: You can also swap the contents of two buttons by
selecting them (hold down the Shift key while
selecting the buttons with the Pointer Tool). Then
select Edit > Swap Buttons.
If the buttons you swap are different sizes, the
contents of both buttons will automatically be scaled.
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Before swap

During swap

After swap

Useful Features

Shuffling Buttons
You can change the relative positions of the buttons
on the boards you have created. This will give your
Boardmaker activities more variety and make each
printed board unique.
1.
2.

3.

Select the Pointer Tool.
Select the buttons (three or more) that you want
to shuffle (hold down the Shift key while selecting
the buttons with the Pointer Tool).
Select Edit > Shuffle Buttons. The contents of
all selected buttons will be randomly shuffled.

Note: As with the swap feature, the shuffled buttons can
be of different sizes. The content of the buttons
will always be scaled appropriately.
Tip:

Hold down the Ctrl key while selecting Shuffle
Buttons. This will force the contents of all the
buttons to shuffle.
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Linking Boards Together
Each board you create can be linked to another board.
This is very useful for assembling pages of a book, for
moving through a series of questions or procedures in
an activity, and for navigating to different activities.
1.
2.
3.

4.
5.
6.

Double-click the button that will link to the next board.
The Button Actions dialog will appear.
Select Change Board in the Action menu (Basics
tab).
A list of boards that have been saved in the current
folder will appear. Select the board to which you
want to link.
Click the OK button.
The Change Board action and the linked board
now appear in the Assigned Actions list.
Click the OK button when finished.
(Continued on next page)
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Double-click the
button you want
to link to
another board.

Select the
board to which
you want to link

Select Change
Board in the
Action menu.

Linking Boards Together

The Recipe button on
the Main Menu board
will be linked to the
Let’s Cook 1 board.

Include Next and Back
buttons for easy
navigation between
boards.

The Lets Cook 1 board
will be linked to the Let’s
Cook 2 board.

Notes: To aid the user in navigation, include a button assigned the Change Board Back action.
Be sure to test your linked boards in the Use mode.
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Adding a Message Display
Adding a Message Display to your boards allows you to
create a variety of writing activities. Button actions such
as Speak, Print, Clear, etc., (Messages tab of the
Button Actions dialog) allow you to control the Message
Display.
1.

2.

Select Message Display in the Dynamic Buttons
menu. (Only one message display is allowed on each
board.)
Click and drag the Message Display to the position
where you want it, and then drag its border to
change its size.

Note: To change the way the text is displayed, select the
Message Display and use the Text menu to set the
font, style, color, and size. (Or right-click the
Message Display and select the desired option.)
Tip:

You can change the color of the Message Display
itself. Select the Message Display, click on the
Color Tool, and select the desired color.
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Making a Button Type a Text Message
You can make a button type a message in the
Message Display by using the Type Message action.
When the button is selected, it will automatically type
the text you have entered into the Speak Message
action dialog, or it will type the text on its face.
1.

2.
3.

Double-click a button that you want to type a
message into the Message Display. The Button
Actions dialog will appear.
Select Type Message in the Actions menu
(Basics tab).
In the Enter Text dialog, enter the message you
want the button to type, or click Use Button Text to
use the text on the face of the button.

Click the OK button when you’re finished.
Note: Be sure to put the program in Use mode to test
the Message Display actions you have assigned.
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Double-click
on button.

Select Type
Message in the
Action menu

Enter text
you want
button to
type.

Using a Message Display

Placing a Picture in the Message Display
You can also create “picture sentences” in the Message
Display. A Message Display can accept picture input
from buttons in addition to text.
1.

2.

3.

4.

Double-click on the button whose picture you want to
place in the Message Display. The Button Actions
dialog will appear.
Select Picture Button in the Actions menu. The
Assigned Actions list will appear:
• Picture Button - tells the button to place its
picture in the Message Display
• Picture Speech - makes the button speak when
selected and the Message Display is spoken.
Edit the Picture Speech action by double-clicking
on the Picture Speech action in the Assigned
Actions list. (See Making a Button Speak on
page 15.)
Click the OK button when finished.

Note: Refer to the in-program Help for more information
on Picture Button actions.
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Double-click
on button.

Select
Picture
Button in
the Actions
menu.

Edit the Picture
Speech action
by doubleclicking in the
Assigned
Actions list.

Working with Movable Buttons

Movable Buttons
Movable buttons allow you to create dynamic
activities for counting, sorting, sequencing, and
more. These buttons can be dragged around the
board and dropped on other buttons to trigger a
spoken message, sound, or other actions.
You can use Movable buttons to further enhance the
activities you create:
•
You can provide corrective feedback by setting
Moveable buttons to “snap back” to their original
positions if they are dropped on an invalid
destination.
•
Moveable buttons can be set to “clone”
themselves to supply unlimited copies for game
and matching activities.
•
You can use advanced programming features
with Moveable buttons to create really unique
and creative activities.

In this sorting and counting activity utilizing Movable
buttons, the student moves the specified number of
shapes into the correct box.
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Creating Movable and Destination Buttons
The Movable Button Tool allows you to pair a
Movable button with a Destination button and assign
actions to be performed when the Movable button is
dropped on the Destination button.

Moveable Button
Tool

The Movable Button Tool is not initially visible in the
Toolbar. Select Dynamic Boards > Show >
Movable Button Tool.
1.
2.

3.
4.

Enter name for Movable
button

Click on the Movable Button Tool.
Click on the button you want to make moveable.
The Enter Name dialog will appear for the
Moveable button.
Enter a name for the Movable button. Then click
the OK button.
Click and drag the Moveable button on top of the
button that will be its destination. Then release
the mouse button. The Enter Name dialog will
appear for the Destination button.

Drag and drop
the Movable
button onto the
Destination
button.

(Continued on next page)
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5.

6.

Tip:

Enter a name for the Destination button. Then
click the OK button. The Button Actions dialog
will appear.
Assign actions to the Destination button that will
be performed when the Moveable button is
dropped on it.

Enter name for
Destination button

Assign
actions to
Destination
button.

To edit the actions for a Moveable-Destination
button pair: Select the Movable Button Tool,
and drag the Movable button on top of the
Destination button you want to edit. (You won’t
have to enter names again.) The Button
Actions dialog will appear, and only the actions
associated with the Movable-Destination button
pair will be displayed.

When you drop
the square into
the green box,
you will hear the
“boing” sound.
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Movable Button Properties
A Moveable button can be set to “snap back” to its
original position if it is dropped on an invalid
destination. A Moveable button can also be set to
clone itself - the original button will stay in place, and
an identical copy of the button will be moved.
1.

2.
3.

4.
Tip:

Right-click on
Movable button and
select Movable
Button Properties.

Right-click on the Movable button that you want to
snap back or to clone itself. Select the Movable
Button Properties option. The Button Properties
dialog will appear.
Select the Snap Back setting if you want the
button to “snap back” to its original position.
Select the Move Clones setting if you want the
original button to stay in place, and copies of the
original button to be moved.
Click the OK button.

Select the Snap
Back setting and/or
the Move Clones
setting.

Select the Center Movables setting under the
Destination Button option to center any paired
Movable button that is dropped on the
Destination button
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